WordPress出现Warning: call_user_func_array() expects parameter 错误修复-ZAERA

当你想换主题的时候,难免会出现各种问题,在这,还要强调一下,一定要做好备份

如何备份呢?

第一种:使用WordPress自带导出导入功能备份和恢复网站(在WordPress后台工具)

第二种:比较友好,但相对麻烦一些,但这些益于恢复。

数据库备份一下,用FTP压缩后把后台图片、主题、插件这些都下载下来。(主要是wp-content这个文件夹)如果是国外的服务器,每天都备份一下,国内的服务器最好一周备份一下,谁能不能保证不会出问题。

第三种:利用一些插件来实现备份(比如BackWPup ),备份到FTP空间、邮箱、Dropbox、Google等

 

如果没有备份的习惯,一定要养成这个习惯,这是很多站长血泪的教训!


说了那么多,下面是正题

今天百度和Google了一下,提供了不同的解决方案。

有一种方案最好用,就是如下:

我的测试环境 wordpress4.8、Php7.1

我们不能修改原文件,采用下策:
屏蔽:php升级到5.4以后导致解决的办法就是在 php的配置文件php.ini中找到display_errors = Off(把on 改为Off)